Open Access

Closed-Loop Network Automation: Architectural Principles from Catalyst Center-Scale Systems

Manevannan Ramasamy
Software Engineering Senior Technical Leader, Milpitas, California, United States of America

Abstract

Enterprise controller platforms must perform operational loop bridging a large and heterogeneous environment of devices, clients, locations, applications and services and must maintain explainability, reliability and safety of changes. The paper is creating a vendor-neutral architecture layout, founded upon the publicly accessible scale attributes of Cisco Catalyst Center, and recognized best practices of intent-based networking, telemetry, assurance and autonomic regulation. The provided framework divides the closed-loop functioning into 6 synchronized planes that comprise: data gathering and contextualization, correlation and diagnosis, intent and policy management, workflow orchestration, outcome verification and external combination. It also introduces hierarchical range of control, evidence amalgamation, categorization of actions and control-budget system in place to keep the remediation activities in stand to reduce the risk of operation. Catalyst Center is considered to be an industry observation source besides source of inner proprietary application and as such the framework might be autonomous of proprietary internals. The framework is evaluated by such criteria as outcome coverage, telemetry freshness, and diagnostic accuracy, control-loop convergence, failover resilience, as well as operator understanding. The resulting architecture provides a procedural basis to the architecture of scaleable enterprise controllers that moderate automation and assurance, explain and guided remediation. The donation is an informed vendor-neutral and product-aware model of trustworthy closed-loop business operations

Keywords

DOI

PDF Download

PDF

Publication Information

JournalInternational Research Journal of Innovative Engineering
Volume6
Number4
Pages10698-10708
Published2022-07-20
IssueVol. 6 No. 4 (2022): International Research Journal of Innovative Engineering (IRJIE)

References

[1] ETSI, Zero Touch Network and Service Management (ZSM); Reference Architecture, ETSI GS ZSM 002 V1.1.1, Aug. 2019. [Online]. Available: ETSI GS ZSM 002 Reference Architecture
[2] Cisco Systems, Introduction to Cisco Catalyst Center API. [Online]. Available: Cisco Catalyst Center API Documentation
[3] M. Behringer et al., “Autonomic networking: Definitions and design goals,” RFC 7575, Internet Engineering Task Force, Jun. 2015. doi: 10.17487/RFC7575.
[4] H. Song et al., “Network telemetry framework,” RFC 9232, Internet Engineering Task Force, May 2022. doi: 10.17487/RFC9232.
[5] A. Clemm, L. Ciavaglia, L. Z. Granville, and J. Tantsura, “Intent-based networking—Concepts and definitions,” RFC 9315, Internet Research Task Force, Sep. 2021.
[6] X. Zheng and A. Leivadeas, “Network assurance in intent-based networking data centers with machine learning techniques,” in Proc. IEEE Int. Conf. Netw. Service Manag. (CNSM), 2021.
[7] A. Leivadeas and M. Falkner, “VNF placement problem: A multi-tenant intent-based networking approach,” in Proc. Int. Conf. Internet Services and Networks (ICIN), 2021.
[8] M. Kiran, E. Pouyoul, A. Mercian, B. Tierney, C. Guok, and I. Monga, “Enabling intent to configure scientific networks for high performance demands,” Future Generation Computer Systems, vol. 79, pp. 205–214, 2018.
[9] A. Rafiq et al., “Intent-based end-to-end network service orchestration system for multi-platforms,” Sustainability, 2020.
[10] A. Rafiq et al., “Intent-based slicing between containers in SDN overlay network,” Journal of Communications, 2020.
[11] A. S. Jacobs, R. J. Pfitscher, R. A. Ferreira, and L. Z. Granville, “Refining network intents for self-driving networks,” in Proc., 2018.

Statistics

93
Views
42
Downloads